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1. Introduction.
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DbCreator is a program for creating Data base of seismograms for further processing by Frequency time analysis program. It's interface is a C++ code using Qt C++ tool kit for multiplatform Graphic User Interface and application development. The computational part of program is based on Data Base package of programs designed by Daniel Quinlan (IRIS corporation). 
The program accepts two formats of seismograms :
- seismograms in SEED format can be retrieved from seismological data centers, via "view processing queue WILBER II" and others;
- seismograms in AH binary files.
See details in Technical_Notes.

· Description of  tool bars and  main window menu is given in  Menu and Tool Bar.
· Procedure of selection of input data is given in  Input data
· The main window containing menu and toolbar, the list of seismic records and console, is described in Main Window.
· Resulting data base is described in Output data.
2. Menu and ToolBar.
ToolBar:
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 Description of options                                                   

[image: image24.png]


    - Generate a new project. Menu option is Project->New and keyboard shortcut is Ctrl+N.
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   - Open an existing project. Menu option is Project->Open and keyboard shortcut is Ctrl+O.
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   - Edit an opened project. Menu option is Project->Edit and keyboard shortcut is Ctrl+E.
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    - Run project. Menu option is Project->Run and keyboard shortcut is Ctrl+R.
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    - Save the project to disk. Menu option is Project->Save and keyboard shortcut is Ctr+S.
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    - Save the project under a new name. Menu option is Project->Save As. 
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     - Exit the application. Menu option is Project->Exit and keyboard shortcut is Ctrl+Q.
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    - Zoom in. Menu option is View-> Zoom In and keyboard shortcut is Ctrl++.
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   - Zoom out. Menu option is View->Zoom Out and keyboard shortcut is Ctrl+-.
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   - Info. Displays a simple yellow message box under cursor about general input information.  
             Push this button to get information in info message box.
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    - Help->Content and keyboard shortcut is F1.
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    - Help->What's This? Provides a single window with an explanatory text that pops up when
             the user asks "What's this?" When you push this button or push keyboard buttons Shift + F1
             the cursor changed to and you can click on any toolbar button to obtain its help text.
             Help->About - Displays a simple message box about DbCreator program.
            Help->About Qt - Displays a simple message box about Qt C++ tool kit.

3. Input Data.
There are two possibilities to start the data base creation: to start a new project (see section I) or to edit an existing project (see sections II and III).


I. [image: image36.png]


 - Generate a new project.


 Click this button and a wizard framework will appeared. A wizard is a special type of input dialog that consists of a sequence of pages. User have to browse or type to fill the empty boxes, lists, radio buttons related to the different items shown in the following pages:

  
1.  Data Page Info.
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Select the type of data in Input type of data frame. The radio button seed volumes - the data base will be created from seed volumes. The radio button ah binaries files - the data base will be created from AH binary files.

Click Browse button, browse the directory on your computer that contains the corresponding type of input data: directory with seed volumes or ah binary files.
Select the type of desirable sampling of seismic records in Output dbase dt frame. Radio button decimate 1 and 10 sec - Input time series will be decimated to 1&10 seconds. Radio button origin dt - Dbase will contain time series with original sampling.
Click Next > button for next page.


2.  Directories Page Info.
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   Type the dbase name in Data base name box.  Click Browse button, browse the directory where output dbase will be placed.
Click Next > button for next page.

3.  Origin Page Info.
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Fill the empty boxes for event date and time information in Date and Time frames. If you selected decimate 1 and 10 sec (in Output dbase dt frame on Data page info page)  then type desirable duration of records in Duration of records frame. 
Click Next > button for next page.

4.  HypoPage Info.
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Fill the empty boxes for hypocenter coordinates and magnitudes in Hypocenter and Magnitudes frames. 
Notes. Depth and Magnitudes may be empty.
Click Finish button to finish the preparation of input data. Main window with the list of station information will appear.
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  -  Open an existing project.
Click this button to open an existing project to browse existing project file. Main window with the list of station information will appear. 

III.  [image: image42.png]


 - Edit an existing project

After open an existing project you can change project parameters clicking this button. 
The wizard framework as in section I will appear. 

IV. Repair an existing project

This possibility is automatically supplied to user, when he opens existing project but some project directories are not exist. It may be input or output directory. Also it may take place when the input directory exists but does not contain needed files.
Repair Project window is the wizard framework and you can check all project parameters open all wizard pages one by one as you did it in section I. 

4. Main window.
The main window contains menu and toolbar ( see Menu and ToolBar), the list of seismic records, and console.
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1. List of seismic records.
The list of seismic records is a tree view frame which can be edited. Check on or check off the check boxes to include correspondent items in the data base, or exclude them. 

Each item in the list if seismic records (Value column) has color indicator to the right of it's check box. Those color indicators are defined as:
   green  - the item with all subitems are acceptable to be included in the data base;
   yellow - the item contains different acceptable subitems and user can change the default selection;
   blue -  the station name is duplicated in the list. Check off all duplicates; 
   red - the item with all subitems it is not acceptable to include in data base.

The value list column of each item (not record item) contains:
   checkable box  which can be in an expanded (subitems are visible) or collapsed (subitems are
   hidden) state;
   checkable box which is checked on for acceptable item or check off  for not acceptable; 
   color indicator;
   item name.

The property list column  contains the subitem name and the number of subitems.
Notations:
Net      - network codes (See Technical Notes )
Loc   - location identifier (See Technical Notes )
Hang -  azimuth of component direction.
Vang -   angle between component direction and the outward-pointing vertical direction.

The record item: 
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   Rec:N  -  N is the number of seismic record fragments,;
   Time interval   - [ fragment start time (counting from the event time), fragment end time];
   Duration   - duration of fragment, 
   Delay        - time delay of the fragment with respect to the end time of preceding fragment, 
                       for the first fragment – with respect to the event time. 
   Dt              - time step, 
   N samples - number of samples.

2. Console.
 The console is output informaion frame where program writes the errors of station information and protocols of running programs which create data base. Errors of station information are following: Z component doesn't exist, one of horizontal components doesn't exist, wrong  component orientations. Every error is indicated in correspondent
line of Property column.


3. Data base creation.

Click the button [image: image45.png]


 (Run project) - The data base will be created. 

4. Saving of the project.

Click the button [image: image46.png]


 (Save the project to disk) to save the project-file under current name. 

Click the button [image: image47.png]


 (Save the project under a new name) to save the project-file under new name.

5. Output data
Detailed data base description can be found at http://www.passcal.nmt.edu/software/datascope/datascope.html .
The Dbase output directory contains data base. Let data base name is dbase and  Dbase is the data base directory.
    Dbase directory contains following directories and files: 
    response/ - instrument response directory   
If input records were decimated to 1&10 seconds then output records are in directories: 
    wf_l/        - binary time series files directory (1 count per second) 
    wf_v/        - binary time series files directory (1 count per 10 second)
If the data base contains time series with original sampling  than output records is in directory
    wf/ - binary time series files directory

    Frequency-time analysis and source inversion programs use following data base tables mentioned below. 

 If input records was decimated to 1&10 seconds:
    "dbase_l.wfdisc"-  Waveform file header and descriptive information. This table provides a pointer (or index) to waveforms stored in wf_l/ directory.
    "dbase_v.wfdisc"- This table provides a pointer  to waveforms stored in wf_v/ directory.

If data base contains time series with original sampling:
    "dbase.wfdisc"- This table provides a pointer  to waveforms stored on wf directory.

    "dbase.instrument" -  calibration information about a station. This table serves three purposes.  It holds nominal one-frequency calibration factors for each instrument.  It holds pointers to the nominal frequency-dependent calibration for an instrument.  Finally, it holds pointers to the exact calibrations obtained by direct measurement on a particular instrument.  See sensor.  
    "dbase.site"- Station location information. Site names and describes a point on the earth where seismic measurements are made ( e.g.  the location of a seismic instrument or array).  It contains information that normally changes infrequently, such as location.  In addition, site contains fields to describe the offset of a station relative to an array reference location.  Global data integrity implies that the sta/ondate in site be consistent with the sta/chan/ondate in sitechan.  
    "dbase.sensor"-  Specific calibration information for physical channels. This table provides a record of updates in the calibration factor or clock error of each instrument, and links a sta/chan/time to a complete instrument response in the relation instrument.  
    "dbase.sitechan"- Station-channel information.This relation describes the orientation of a recording channel at the site referenced by sta.  This relation provides information about the various channels (e.g.  sz, lz, iz ) that are available at a station and maintains a record of the physical channel configuration at a site.  
    "dbase.origin" - Data on event time, location and magnitude. 

6.Technical Notes:
1. Seismograms in SEED format can be retrieved from few data centers:  http://www.iris.washington.edu/manuals/netdc/netdc_user.htm   , via "view processing queue WILBER II":   http://www.iris.washington.edu/cgi-bin/wilberII_page1.pl or  http://www.iris.edu/data/WebRequest.htm.  Transform them from SEED to DB DATASCOPE format, and store them.
2. Program DbCreator uses rdseed program to create AH bin files from all of seed volumes (directory SeedVols , files  *.seed) and puts these AH bin files into working directory “work”. Program rdseed is placed in /opt/fmt/bin directory. The text file </opt/fmt/bin/fmtRdseed.initial> contains information for DbCreator program. Using this file DbCreator creates temporary file for rdseed program providing AH bin files extraction from rdseed volume.  Such program design allows working with AH bin files directly. Make sure that last extension name of each file is “AH” (for example “1997.288.00.16.45.8310.IU.WVT.01.LHN.AH” or ”WVT.LHZ.AH”, or “1.AH”).  
If you work with the files those not created with the program rdseed, do not use file names containing more than 5 dots. It is recommended to use 'rdseed' standard name format:   yyyy.ddd.hhh.mm.ss.ffff.NNN.SSSSS.LLL.CCC.Q.AH  
(See http://www.iris.edu/manuals/rdseed.htm). Here yyyy is the year, ddd is the Julian day, hh.mm.ss.ffff is the time of day of the start of the first record, SSSSS is the station name, and CCC is the   component name for the particular seismogram being recovered, NNN is Network codes, LLL is Location identifiers, Q is specify data type ( E - Everything, D - Data of undeteminated state, R - Raw waveform data, Q - Quality controlled data, some processes have been aplyed to the data).
3. Program allows decimating of time series to 1 sample per second and to 1 sample per 10 seconds. The decimate rate must be a multiple of the product of 2,4,5.
The program allows to keep the original sampling. 
4. Network codes are assigned by the FDSN archive (IRIS DMC) to provide uniqueness to seismological data streams.
Look at    http://www.iris.washington.edu/FDSN/networks.txt (permanent) 
and   http://www.iris.washington.edu/FDSN/networks.portable.txt (temporary).
5. In 1998, the DMC started to use location identifiers to identify uniquely a data stream among many data streams for the same channel id and station id.
          EXAMPLES:      1997.288.00.16.45.8310.IU.WVT.00.LHN.AH and 1997.288.00.16.45.8310.IU.WVT.10.LHN.AH means there are two different instruments at the ANMO sight that use the BHZ channel designation.
              (For more information about how location identifiers are applied, please read this DMC Electronic Newsletter article. http://www.iris.washington.edu/newsletter/vol1no1/page1.htm)
              If a station does not use location identifiers, the file name will look something like this: 1997.288.00.16.45.8310.IU.WVT..LHN.AH. For instance if you have an STS-1 and STS-2 BHZ channel the location id could be:
    00 for the STS-1 (primary stream) 
    10 for the STS-2 ( the secondary stream) 
    20 for other sensors, etc

6. More details concerning IRIS (Data Sources, Request Methods, Manuals, Software, Services etc.) can be found in http://www.iris.washington.edu/HTM/manuals.htm.
7. More details concerning DB DATASCOPE can be found in  http://www.passcal.nmt.edu/software/datascope/datascope.html
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1. Introduction.

The program FTAN was designed for processing of seismic surface waves records by methods of spectral and frequency-time analysis. It is a Colorado University product designed by Profs. A. L. Levshin and M. Ritzwoller with their assistants and students. The program uses input data in CSS Datascope format. The output of program is also CSS formatted database containing cleaned waveforms. It's possible to export measured group velocities in ASCII format and cleaned waveforms in AH or ASCII formats. Program FTAN works under control of "Ftan control panel" program named ftan. Using ftan program you define input data, processing parameters, start FTAN as external program, and communicate with it.

 
FTAN code  is a fortran code. Program ftan is  a C++ code using Qt C++ toolkit for multiplatform Graphic User Interface and application development.


 2. Main Window.


   2.1 The ToolBars.
       2.1.1 Location Toolbar.
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   We define as location a directory containing FTAN output materials: 
    a) subdirectory with cleaned waveforms; 
    b) subdirectory with dispersion files; 
    c) output tables (table.wfdisc related to cleaned records and tables related to dispersion  files); 
    d) postscript files. 
    e) subdirectory wfah contains  cleaned wave forms in ah format;
    f) subdirectory  wfascii  contains  cleaned wave forms in ah ascii format;
    g) subdirectory  dispascii  contains  dispersion files in ascii format
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    -  Create a new location. Correspondent menu option is Location->New and keyboard shortcut is  Ctrl+N.
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    -  Open an existing location. Menu option is Location->Open and keyboard shortcut is  Ctrl+O.
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    -   Save currently open location. Menu option is Location->Save and  keyboard shortcut is  Ctrl+S.
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   -   Save the current location under a new name. Menu option is  Location ->Save as....
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   -   Zoom in - increases the font size. Keyboard shortcut is Ctrl++.
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   -   Zoom out - decreases the font size. Keyboard shortcut is Ctrl +-.
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   -  Export of cleaned waveforms (in AH and/or AH ASCII format) and measured group velocities (ASCII file) into the selected directory. The menu option is Location->Export.         
[image: image57.png]


   -  Close ftan. Menu option is Location->Exit and keyboard shortcut is  Ctrl+Q. 


 2.1.2 Settings Toolbar.
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Settings toolbar is intended for assignment of FTAN specifications.
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-  Main settings. Menu option is Settings->Main; keyboard shortcut is  (Ctrl+M).
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- Toggle button. If the button is pressed then postscript files will be created. The menu option is  Settings->Ps On/Off and the keyboard shortcut is (Ctrl+P).
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- Toggle button.  If the button is pressed then polarization measurement will be performed.   
The menu option is Settings->Polar On/Off and the keyboard shortcut is (Ctrl+R).
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- Assignment of parameters for bandpass filtering. The menu option is  

Settings->Filter Spec and the keyboard shortcut is (Ctrl+F).
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- Assignment of parameters defining FTAN window.
The menu option is Settings->Fta Window and the keyboard shortcut is  (Ctrl+W).
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- Selection of waveform components to be plotted. The menu option is 

Settings->Plot Comp and the keyboard shortcut is  (Ctrl+L) . 
[image: image65.png]


- Selection of waveform components for FTAN processing. The menu option is 

Settings->Fta Comp  and the keyboard shortcut is  (Ctrl+T) .
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- Assignment of orbit number. The menu option is Settings->Orbit.
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- Assignment of mode number. The menu option is Settings->Mode and the keyboard shortcut is (Ctrl+D) . 

  2.1.3 Tools Toolbar.
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Tools toolbar is intended for performance of FTAN processing and view of results.
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- Start FTAN processing.  The menu option is Tools->Start and the keyboard shortcut is   (Alt+R) .
[image: image70.png]


 - Plot selected waveforms. The menu option is Tools->Wave and the keyboard shortcut is   (Alt+W) .
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-  Apply bandpass filtering to waveforms raw data. The menu option is Tools->Filter and the keyboard shortcut is    (Alt+I) .
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 - Start the performance of floating filtering. The menu option is Tools->Fta   and the keyboard shortcut is  (Alt+F) .
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  - View calculated group velocity curves. The menu option is Tools->Velocity   and the keyboard shortcut is   (Alt+V) .
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 - View cleaned and raw amplitude spectra. The menu option is Tools->Amplitude and the keyboard shortcut is (Alt+A) .
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 - View estimated polarization anomalies. The menu option is Tools->Polarity   and the keyboard shortcut is    (Alt+P) .
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 - View cleaned and raw seismograms. The menu option is Tools->Overlay and the keyboard shortcut is   (Alt+O) .
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 - View a FTAN diagrams for cleaned and raw records. The menu option is Tools->Image and the keyboard shortcut is  (Alt+M) .
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-  Clean results of processing for chosen components. The menu option is Tools->Clean   and the keyboard shortcut is   (Alt+N) .
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- Save results of processing. The menu option is Tools->Save   and the keyboard shortcut is   (Alt+E).
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 - Draw map for distribution of all available stations (if the In Tab in the   main window is shown) or draw map for distribution of stations correspondent to  saved  processed  records  (if  the Out  Tab  in  the  main window is shown).    
The menu option is Tools->Draw Station Map  and the keyboard shortcut is (Alt+T) 
2.2 Central Area. 

 2.2.1  In Tab.
The In Tab first column "sta/chan" in Central Area contains the names of seismic stations and available channels. The second column "state" contains indicator showing the status of station or channel.

The channel indicator selected appears after the cleaned channel records were saved (selected for output). The channel indicator rejected appears after the channel (which is not selected) was rejected manually. To perform the rejection click by right mouse button on the channel, pop up menu "reject" will appear, click it by mouse button. 
The station indicator selected appears after at least one cleaned channel record is saved. The station indicator rejected appears after all channels are rejected. A station which is not selected can be rejected manually in the same way as channel (in this case all channels will be marked as rejected).
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2.2.2  Out Tab.
The Out Tab first column " sta/rec " in the Central Area contains names of seismic stations and components of cleaned records. The second column "state" contains (a) the number of cleaned records for correspondent station, and (b) orbit number and the time of record creation. The creation time is given in format: dd/MM/yyyy hh:mm:ss.

The Out Tab provides the tools for selected (saved) records deleting and for viewing of postscripts produced by FTAN during the record processing. To perform the deleting of any record click on it by right mouse button, pop up menu will appear. Click on the item "delete". To view the postscripts click on the item "view ps", the window "View Postscript Dialog" will appear. This dialog window handling is described below in paragraph 4.14.
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 2.3 Status bar.
The status bar contains the information about current operations. 

3. The Menu Entries.


 3.1 Location.
The keyboard shortcut is   (Alt+L).The following functions are available from the Location menu: 

[image: image83.png]


  Location->New... (Ctrl+N)       -    Create a new location. 
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Location->Open... (Ctrl+O)      -   Open an existing location. 
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Location->Save (Ctrl+S)           -  Save the currently open location. 
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Location->Save as...                  -   Save the currently location under a new name. 
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Location->Export                      -  Export of cleaned waveforms (in AH and/or AH ASCII

 



           format) and measured group velocities (ASCII file) into the

                                                           selected directory.
Location->Open Recent                 -  Displays a list of recently opened location to choose from. 
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Location->Exit (Ctrl+Q)            -  Close ftan. 

3.1 Settings.
The keyboard shortcut is  (Alt+S).The following functions are available from the Settings menu: 

Settings->Total Settings...              -  Full configuration of all parameters.
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  Settings->Main Settings (Ctrl+M) -  Configuration of main parameters.
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  Settings->Ps On/Off (Ctrl+P)        -  Toggle button. If the button is pressed then postscript files will be created.
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Settings->Polar On/Off (Ctrl+R)   -  Toggle button.  If the button is pressed then polarization measurement will be performed.   
  
[image: image92.png]


Settings->Filter Spec (Ctrl+F)       -  Assignment of parameters for bandpass filtering.
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  Settings->Fta Window (Ctrl+W)   -  Assignment of parameters defining FTAN window.
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  Settings->Plot Comp (Ctrl+L)       -  Selection of waveform components to be plotted. 
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Settings->Fta Comp (Ctrl+T)       -  Selection of waveform components for FTAN processing.
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  Settings->Orbit                           -  Assignment of orbit number.
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  Settings->Mode (Ctrl+D)             -  Assignment of mode number.

3.3 Tools .
The keyboard shortcut is   (Alt+T). The following functions are available from the Tools menu: 
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Tools->Start (Alt+R)               -  Start FTAN processing.  
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Tools->Wave (Alt+W)            - Plot selected waveforms. 
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Tools->Filter (Alt+I)                - Apply bandpass filtering to waveforms raw data.
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Tools->Fta  (Alt+F)                 -  Start the performance of floating filtering. 

[image: image102.png]


Tools->Velocity  (Alt+V)        - View calculated group velocity curves. 

[image: image103.png]


  Tools->Amplitude  (Alt+A)    -  View cleaned and raw amplitude spectra. 
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Tools->Polarity  (Alt+P)           - View estimated polarization anomalies. 
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Tools-> Overlay (Alt+O)           - View cleaned and raw seismograms. 
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Tools-> Image  (Alt+M)          - View a FTAN diagrams for cleaned and raw records.
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  Tools->Clean  (Alt+N)            -  Clean results of processing for chosen components. 
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  Tools->Save  (Alt+E)              -  Save results of processing. 
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   Tools->Draw Station Map  (Alt+T)    -   Draw map for distribution of all available stations (if the In Tab in the   main   window is shown) or draw map for distribution of stations correspondent to  saved  processed  records  (if  the Out  Tab  in  the  main window is shown).                                   


3.4 Help.
The keyboard shortcut is   (Alt+H). The following functions are available from the Help menu: 
Help->Content    (F1)
Help->About                          -  Displays a simple message box about ftan program. 
Help->About Qt                     -  Displays a simple message box about  Qt C++ toolkit.
Help->What´s This   (Shift + F1) 

Ftan program  provides online-help, with three levels of detail: 


1.Tool Tips and Status Tips.
 Tool Tips is extremely brief help, that appears when cursor is hanging over a toolbar button for a certain period of time. Tool Tips are presented with black text on a yelow background.  Status Tips are also a short piece of descriptive text, a little longer then a tooltip. When the mouse hangs over a toolbar buton, a status tip appears in the Status bar.

2.What's This?  provides a single window with an explanatory text that pops up when the user asks "What's this?" When you push button [image: image110.png]4



or push keyboard buttons  (Shift + F1) the cursor changed to [image: image111.png]4



  and you can click on any toolbar button to obtain its help text.

3.Online Help is provided by a help browser.  Ftan program have  a "Content" entry in the Mane Window Help menu and help buttons in Central Area of Main Window (In Tab and Out Tab .) Click "Content"  entry of Windows Help menu (keboard button -  F1) to open ftan HTML-based program manual. 


4. The Dialogs.


4.1 The New Location.
[image: image112.png]


 Location->New... (Ctrl+N) 
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Browse ‘wfdisc’, ‘instrument’, ‘origin’ tables. If the origin table contains one row, gray label ‘Event’ appears. It's the event information: day/month/year hour:min:sec, latitude longitude, depth. If origin table contains information about more then one event, the following window appeares:
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This window shows the first origin table row and number of such rows. Click the button at the right end of the row, a window containing complete origin table will appear:
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Select a row and click OK. Selected Event information will appear in New Location Dialog. Click button Ok to work with new location.

Click Cancel to leave the dialog without opening a new location.


4.2 The Open Location.
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  Location->Open... (Ctrl+O) 
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This dialog is assigned to open an already existing directory. The window shows the current directory and it's subdirectories. Click once on directory to select it. Click OK to open the selected directory. Click Cancel to leave the dialog without opening a new directory.
 
   4.3   Save as… and Save Location
          [image: image118.png]


 Location->Save (Ctrl+S)
This button and menu option are assigned for saving the location. In the case of new Locaton

the Save Location As Dialog will be invoked for selection of directory name.

          [image: image119.png]


 Location ->Save as...

[image: image120.png]K4 Save As Location

Look In: ['=3 roottestFtan/mainDirectory/

Cleanedwf

it

response

(S temp-1093960155
wi_l

Wiy

Directory: o

l_rne type: -] cancel





This window shows the current directory and it's subdirectories. 
1. Using an existing directory as saved location you have two possibilities:
(a) Click once on selected directory and directory name will appear in 'Directory' box. Click OK to save the location.
(b) Double click on selected directory will open this directory. Name of selected directory will appear in 'Look in' combobox. 'Directory' box will be empty. Click OK to save the location.
2. To save the location as a new directory click the 'Create New Folder' toolbar button to create the new directory. Then rename it using popupmenu which appeared pushing right mouse button. Then use one of  possibilities described above. 

[image: image121.png]



Location->Exit (Ctrl+Q) 
This button and menu option are designed for program exit. If you will push this button without preliminary save of location (FTAN parameters and results of processing) the program will remind you to save the location. 

4.4 Total Settings.

Settings->Total Settings...
Total Parameter Settings window provides the tool for editing of the values of FTAN parameters. 
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The first column contains the titles (italic font) of groups of parameters, the collective names for a set of related parameters (accompanied by '+'), and single parameter names.
The second column contains the parameter values. To change the value of any parameter click the correspondent row in any place. A row dialog window will appear. There are five different

types of row dialog (the descriptions and examples are shown below). 

To close row dialog click second time on first column in any place or OK button or <Enter>. 
To close row dialog without changes push button [image: image123.png]


  . To set default values for all row dialog parameters push button [image: image124.png]


.  If any parameter was changed it's name will be rewritten by bold font. 

Bottom row of buttons of Total Parameter Settings window:

Default button - to set default values for all parameters;
Reset button - to remove last changes for all parameters;
Initial button - to set initial parameter values (at the moment of start of location session) for all parameters ;
 OK button or Enter button - to exit Total Parameter Settings with changed parameters (all row dialogs must be closed); 

Cancel - to exit without changes.


Five Types of Row Dialog


  1. Row of check box widgets. 

Input dialog values are given as a list of characters. Output dialog values form a list of selected characters. To select any character click on the nearest to it from the left checkbox. You can close this dialog if at least one of characters is selected.
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  2. Combo box widget. 

Input dialog value is a string of text parameters. Output dialog value is a text item selected in the combo box widget. To select an item click on it.
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 3. LineEdit box widget. 

Input dialog value is a floating-point number. Output dialog value is an edited number.
The program checks if the number meets the conditions defining maximum and minimum values and number of digits after the decimal point (minimum, maximum, decimals).  
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4.  Spin box widget. 

Input dialog value is an integer number. Output dialog value is the edited number.
Spin box ensures that a string contains a valid integer within a specified range. 
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5. ReadOnly LineEdit box widget. 

Input dialog value is a set of related float or integer numbers. 
 LineEdit box widget provides viewing of values of related parameters and setting of their default values. The program checks if the values of related parameters are ordered in required way if it is necessary.
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Detailed description of the Total Parameter Settings window.    


1. Project – complete pass of location.

2. Window characteristic.

      Property - "window size"
                  Type of row dialog - combo box widget
                  Value list - "Small", "Large"
                  Default  - "Large"
                  Description -  Size of plotting window.

                  Property - "mode" 
                  Type row dialog - combo box widget
                  Value list    - "Portrait", "Landscape" 
                  Default  -  "Landscape"
                  Description -   Output pictures orientation. 

                  Property - "postscript output" 
                  Type row dialog - combo box widget
                  Value list    -  "No Yes" 
                  Default  - "Yes"
                  Description -   If value "Yes" is chosen, then postscript files will be created. 

3. Plot characteristic

                  Property - "wave type for overplot"
                  Type row dialog - combo box widget
                  Value list   -  "Rayleigh, Love, Rayleigh&Love"
                  Default  - " Rayleigh&Love"
                  Description -   Type of waves for over plotting of raw and cleaned records. 

                  Property - "Plot PREM group vels"
                  Type row dialog - combo box widget
                  Value list   -  "Rayleigh, Love, Rayleigh&Love, No"
                  Default  - " Rayleigh&Love"
                  Description -   To plot PREM group velocity curves on resulting picture for

                  estimated group velocities. 

                  Property - "X-axis scaling"
                  Type row dialog - combo box widget
                  Value list    -  "Periods, Frequencies"
                  Default  - "Periods"
                  Description -   FTAN map X axis scaling.

4.Waveform:
                  Property - "Record components to be plotted"
                  Type row dialog - row of check box widgets
                  Value list    -   "z, n, e, r, t"
                  Default  - "z, r, t"
                  Description - Waveform components to be plotted at the start of processing.

Property - "Waveform filter specification"
                  Type row dialog – ReadOnly LineEdit box widget
                  Value list    -  List of float numbers
                  Sort order – ascending
                  Description - Band pass filter parameters.  Two left and two right bounds for cosine

            window (in seconds).

                           Property - "Short period zero"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "10.00"  
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  short zero period. 

                           Property - "Short period corner"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "15.00"
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  short corner period.

                           Property - "Long period corner"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "300.00"
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  long corner period.

                           Property - "Long period zero"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "350.00"
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  long zero period.

5.Measurement specification:
                                                            
                  Property - "Apply instrument response" 
                  Type row dialog - combo box widget
                  Value list   -  "False True" 
                  Default  - "True"
                  Description - Apply correction for instrument response.    

                  Property -  "Components to be processed"    
                  Type row dialog - row of check box widgets
                  Value list    -   "Z, R, T," 
                  Default  - "Z, T"
                  Description -  Components to be proceeded by FTAN.  

                  Property - "Polarization measurement" 
                  Type row dialog - combo box widget
                  Value list   -  "False, True" 
                  Default  - "True"
                  Description -  If selected "True" then polarization measurements will be performed. 

                       


6. Analysis limits:

                  Property - "Group velocity bounds (km/s)",
                  Type row dialog - ReadOnly LineEdit box widget
                  Value list    -  List of float numbers
                  Sort order - ascending
                  Description -  Minimum and maximum values of group velocity for FTAN diagram

                  (km/sec). 

                           Property - "min"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "2.00"
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  Minimum value of group velocity.

                           Property - "max"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "6.00" 
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  Maximum value of group velocity.

                  Property - "Period bounds (sec)",
                  Type row dialog - ReadOnly LineEdit box widget
                  Value list    -  List of float numbers
                  Sort order - ascending
                  Description -  Minimum and maximum values of period for FTAN diagram (sec).

                           Property - "min"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "10.00"
                           minimum – 0, maximum - FLT_MAX; decimals - 2    
                           Description -  Minimum period value.

                           Property - "max";
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "350.00"     
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  Maximum period value.

                  Property -"Numbers of orbit and mode"
                  Type row dialog - ReadOnly LineEdit box widget
                  Value list    -  List of integer numbers
                  Sort order - no
                  Description -   Numbers of orbit and mode.  

                           Property - "Number of orbit"
                           Type row dialog -  Spin box widget
                           Value    -   integer number
                           Default  - "1"
                            minimum - 1, maximum - 16; unsigned value  
                           Description -  Orbit number.

                           Property - "Number of mode"
                           Type row dialog -  Spin box widget
                           Value    -   float number
                           Default  - "0"
                           minimum - 0, maximum - 4; unsigned value      
                           Description -  Mode number.

                  Property - "Raw spectrum: group velocity (km/s) and width (s)" 
                  Type row dialog - ReadOnly LineEdit box widget
                  Value list    -  List of float numbers
                  Sort order - ascending
                  Description -  Raw spectrum for comparison with cleaned one is calculated in 

                  time segment of given width centered at time correspondent to given group

                  velocity value. 

                           Property - " group velocity"
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "3.60"
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  group velocity value correspondent to the center of time 

                           segment for raw spectrum calculation.

                           Property - " width" 
                           Type row dialog - LineEdit box widget
                           Value    -   float number
                           Default  - "1800.00"
                           minimum - 0, maximum - FLT_MAX; decimals - 2 
                           Description -  Width of time segment for raw spectrum calculation.

4.5 Main Settings.

[image: image130.png]


Settings->Main Settings (Ctrl+M).

Program provides the tool for editing of main parameters only. It can be done with help of Main Parameter Settings window. 
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The detailed description of parameters and dialogs is given in paragraph 4.4.


4.6  Filter specification.
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Settings->Filter Spec (Ctrl+F)  
Type parameters for bandpass filtering: short period zero, short period corner, long period zero, long period corner. The program checks if this numbers are given in ascending order.
You can use default button to set default values for all of dialog items. 
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Click OK button to close the window with new parameter values, or Cancel - to close the window without changes.



4.7 Ftan Window.
[image: image134.png]


Settings->Fta Window (Ctrl+W)
Type parameters for group velocity and period bounds of FTAN diagram. You can use default button to set default values separately for group velocity bounds and period bounds.
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Click OK button to close the window with new parameter values, or Cancel - to close the window without changes.

4.8 Plot Components.
[image: image136.png]


Settings->Plot Comp (Ctrl+L)  
Click component toggle buttons required for plotting to switch them on or off. You can use default button to set default values for all of dialog items.
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Click OK button to close the window with new parameter values, or Cancel - to close the window without changes.


4.9 Ftan Components.
[image: image138.png]


 Settings->Fta Comp (Ctrl+T)
Click component toggle buttons required for FTAN processing to switch them on or off. You can use default button to set default values for all of dialog items.
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Click OK button to close the window with new parameter values, or Cancel - to close the window without changes.


4.10 Orbit Settings.

[image: image140.png]


  Settings->Orbit    
Click required orbit number in pop up menu shown below. 
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4.11 Mode Settings.

[image: image142.png]


 Settings->Mode (Ctrl+D)    

Choose the required mode number either by clicking the up/down buttons or by typing the value directly into the spin box. If the value is entered into the spin box directly, <Enter> or <Return> must be pressed to apply the new value. You can use default button to set default values for mode number.

                                             [image: image143.png]KEdMode Setting Dialog =3
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Click OK button to close the window with new parameter value, or Cancel to close the window without changes.



4.12 Clean Records.

[image: image144.png]


  Tools->Clean  (Alt+N)

Click component toggle buttons required to be cleaned to switch them on or off. 
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Click OK button to perform the cleaning, or Cancel - to close the window without cleaning.

4.13 Save Records.
[image: image146.png]


  Tools->Save  (Alt+E)  
Click component toggle buttons required to be saved to switch them on or off. 
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Click OK button to save records, or Cancel - to close the window without saving.


4.14 View Postscript.
Click Out tab in Central Area of MainWindow.
Click right mouse button on channel required, pop up menu will appear:
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Click "view ps". View Postscript window will appear. Select a line and click OK button to view correspondent postscript file. To close the window click Cancel.

[image: image149.png]PAF LbHZ 31.08.2004 20:53:59
Cleaned and raw seismograms

Estimated polarization anomalies
Diagrams for cleaned and raw records

Calculated group velocity curves
Cieaned and raw amplitude spectra







4.15 Export of cleaned waveforms and measured group velocities

[image: image150.png]


Location->Export
Select location as was described in paragraph 4.3. Select format and click OK button.
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You can export following output results (formats):

(1) AH records - cleaned waveforms in AH (binary) format;

(2) ASCII records - cleaned waveforms in ASCII format;

(3) ASCII disp. curves – measured group velocities in ASCII files (number, central filter period, apparent period, group velocity).

Every exported file name contains the correspondent station name and the time of record processing.

5. Processing performance

Until you didn’t select a station and a channel to be processed the light of semaphore button is red [image: image152.png]


.  Click on ‘+’ near selected station, available channels will appear. Click on one of them. The semaphore light will change to yellow [image: image153.png]


. The program is ready for processing of selected seismograms. Click on semaphore button. The semaphore light will change to green [image: image154.png]


, and selected waveforms will be plotted 
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Note, that the raw waveforms can be plotted at any moment by clicking on the button [image: image156.png]


 .


To apply bandpass filtering click the button [image: image157.png]


.   Filtered records will be plotted

            [image: image158.png]2.40e404

1.60e+04
% 8.00e+03
5 0.00e+00
2
8.00e+03
~1.600+04

—2.40e+04
3000 4000 5000

2.00e+04

1.606+04

1.20e+04
o 8.000+03
I 4.000+03
5 0.00e+00
=4.000403
~8.00e+03
~1.20e+04
~1.60e+04
-2.00e+04
3000 4000 5000

3.200+04

2.40e+04

1.60e+04
™
3 8.00e+03
,2_ 0.00e+00
~8.00e+03
—1.608+04
—2.40e+04

3000 4000 5000

time from origin (seconds)





To view FTAN maps for selected components and to make floating filtering push the button [image: image159.png]


.
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To make a floating filtering it is necessary to plot dispersion curve to make phase equalization (black circles). Use mouse to do this. Click left mouse button to put a point and the right one to delete the point nearest to cursor location. Type “e” to finish the plotting. 

The picture of envelope of signal will appear: 
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It is necessary to cut a signal which you've selected. This signal is concentrated near the center of picture (red vertical line). To do this you must set four points to define the filtering window with cosine edges. Use the same commands as above. 

The  picture of FTAN map for a cleaned signal will appear: 
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You can continue with filtering of this component. If you're satisfied with the result of filtering type "y".  FTAN diagram of next component will appear.

Note: to interrupt the floating filtering process type “q” . 
View of results

 To view results of FTAN calculation of group velocities click button [image: image163.png]


. Here is an example of group velocities plotting.
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The black lines are theoretical curves for PREM model.

To view amplitude spectra push the button [image: image165.png]


 .

Here is an example of picture of amplitude spectra:
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Thin lines present the amplitude spectra of raw signals; thick lines present the amplitude spectra of cleaned signals.

To view the FTAN estimates of polarization anomalies push the button [image: image167.png]


.

Here is an example of picture of polarization anomalies: 
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To view the picture of cleaned and raw seismograms push the button [image: image169.png]


.

Here is an example of picture of filtered and raw signals:
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To view a picture of FTAN diagrams for cleaned and raw records push the button [image: image171.png]


. 

Here is an example of picture of FTAN maps for filtered and raw seismograms:
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To clean any of processed components push the button [image: image173.png]


. The Clean Records Dialog 

window will appear. 
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Click component toggle buttons required to be cleaned. Click OK button to perform the 

cleaning, or Cancel - to close the window without cleaning.

To save results click the button [image: image175.png]


.  The Save Records Dialog will appear.


[image: image176.png]K Save Dialog





Click component toggle buttons required to be saved. Click OK button to save records, or Cancel - to close the window without saving.

Select next station-channel.  Button  [image: image177.png]


 changes green color to yellow [image: image178.png]


 and you can work with new selection.
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